Sign in to follow this  

Can't get past last Tablet for Saga Cardinal quest

Recommended Posts


I get to the last tablet  paragraph 17 from here

When I kill the Angel nothing happens and  Winter Hunter Kadyth says "I've missed.... Beter  luck next time".

He disappears in ~5min and when I try again it's exactly the same. I've tried already 10+ times.


IGN: LorenStrawberry

Here's the video

I tried different things:

- I checked that my inventory has space

- I restarted the client

-  I've updated the client

- I've launched the game on another PC

- I did the same quest with a different char an hour ago and it worked. But not with this cardinal

- No one in the party

- I tried to last hit it with a melee attack

- I tried to let the NPC last hit it, but it has too low damage for that



Edited by deathangel

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this